Support for Windows Vista

BreezeBrowser Pro - BreezeBrowser Pro v1.7 and later will run on Windows Vista without any problems. Older versions may require data execution prevention to be turned off.

Canon PowerShot raw conversion on Vista: The latest Canon PowerShot raw conversion libraries supplied to developers are not compatible with Windows Vista. When updated libraries are available these will be included with BreezeBrowser Pro. In the meantime the following workaround can be used to enable Canon PowerShot raw conversion on Vista:
1) Download and install the Canon RAW Codec for Windows Vista. This can be downloaded from Canon's website - select "Digital Cameras", "PowerShot G Series", "PowerShot G5" and press the "Go" button then set the "Select OS" dropdown list to "Windows Vista" and the Canon RAW Codec can be found under the software section. Download this file and run it to install the Canon RAW Codec on your PC.
2) Copy the following files from the Canon RAW Codec folder (e.g. C:\Program Files\Canon\RAWCodec120) to the BreezeBrowser Pro folder (C:\Program Files\BreezeSys\BreezeBrowserPro): rcDcd.dll, rcDvlp.dll, rcParse.dll, rdDcd.dll, rdDvp.dll, rdParse.dll

Downloader Pro - Downloader Pro v2.0.3 and later will run on Windows Vista without any problems. Older versions may may require data execution prevention to beturned off. Please note that Windows AutoPlay on Vista will only work with Downloader Pro v2.0 onwards. Images can be downloaded using a card reader or from a camera which can be accessed as a mass storage device (i.e. appears as a external storage device in Windows Explorer and is assigned a drive letter) or from one of the following Canon EOS cameras: Canon EOS-1Ds Mark II, Canon EOS-1D Mark II, Canon EOS-1D Mark II N, Canon EOS 5D, Canon EOS 30D, Canon EOS 20D, Canon EOS 400D, Canon EOS 350D, Canon EOS Digital Rebel XTi, Canon EOS Digital Rebel XT

DSLR Remote Pro - DSLR Remote Pro v1.4 and later fully supports Windows Vista to control the following cameras: Canon EOS-1Ds Mark II, Canon EOS-1D Mark II, Canon EOS-1D Mark II N, Canon EOS 5D, Canon EOS 30D, Canon EOS 20D, Canon EOS 400D, Canon EOS 350D, Canon EOS Digital Rebel XTi, Canon EOS Digital Rebel XT
Canon do not provide Windows Vista drivers for older cameras such as the Canon EOS 10D and these cannot be controlled on Windows Vista using DSLR Remote Pro (but they can be controlled on Windows XP, Windows 2000, Windows ME and Windows 98 SE).

PSRemote - Now supported by PSRemote v1.5.8 for recent PowerShot models. Older PowerShot models are only supported if USB drivers for Vista are available on Canon's website.

Data Execution Prevention (does not apply to BreezeBrowser Pro v1.7 and later, Downloader Pro v2.0.2 and later or DSLR Remote Pro v1.4 and later)
The software protection libraries used by earlier versions of BreezeBrowser Pro and DSLR Remote Pro are not compatible with Windows Vista data execution prevention and so this needs to be turned off or an exception made in order for them to run. This can be done by running System from the Control Panel then clicking on the Advanced tab. Then click on the Settings button in the Performance section and click on the "Data Execution Prevention" tab. Please see the Windows Vista help files for more information about data execution prevention.
Instructions for turning off data execution prevention

Home | Products | Purchase | Download | Support | Reviews | About | News | Links

© Copyright Breeze Systems 2008

Breeze Systems - Support for Windows Vista